This project is read-only.

Can't get FitToViewRestrictions to work with build 28448

Aug 13, 2009 at 12:32 PM


I have been using the FitToViewRestrictions collection as described in this thread and using the D3 build linked to in the same thread.  However, when I downloaded a more recent nightly build (28448) I can't seem to get it to work again.

Whenever Apply is called on my ViewportRestriction derived class, oldDataRect is always {(0;0) -> 1*1} and newDataRect is always {Empty}.

Does that make sense?  Any ideas why this is happening?

Best regards,

Aug 14, 2009 at 9:37 AM

Actually, I just tried it without using the FitToViewRestrictions collection at all and the normal Fit to view behaviour doesn't seem right.  Is this a known issue?


Aug 25, 2009 at 8:48 PM

Well, this is strange. Have you tried the code from the 'Nightly' branch of the latest changeset in 'Source code' page?


Aug 26, 2009 at 2:57 PM

Hi IanR,

I have specially checked that in the latest development version it's all ok with restrictions both in Restrictions and FitToViewRestrictions collections.

Can you please give me a sample that reproduces this case?

You can email me to




Aug 26, 2009 at 3:40 PM

Hi Mikhail,

Thanks for checking this.  I've just downloaded the latest code (28547) and using the Nightly build I am still getting some strange Fit to view behaviour.  I'll put together a sample that reproduces it and send it on to you.

Best regards,